1

Тема: Онтопик

Под линуксом не конпеляется, Фигец. Я что-то делаю не так?

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

2 (изменено: nexfwall, 2014-10-03 11:22:31)

Re: Онтопик

ZAGNU пишет

Под линуксом не конпеляется, Фигец. Я что-то делаю не так?

Стопудово что-то делаешь не так.
Лаунчер для сборки требует Qt >= 5.3 (qtbase), и quazip ~= 0.5.
Для работы требует quazip собранный под Qt >= 5.3, иначе фиг тебе, а не распаковка архивов.

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

3

Re: Онтопик

ZAGNU пишет

Под линуксом не конпеляется, Фигец. Я что-то делаю не так?

Не копипастишь лог ошибки.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

4

Re: Онтопик

Компилируется, но не запускается. Падает при обращении к окну мышью или клавиатурой
Ниже вывод сборки и запуска через эмулятор терминала. При сборке через QtCreator особо ничего не меняется, разве что видно, что приложение падает на return a.exec(); из main.cpp

Spoiler

ruslan@debian:~$ cp -r ttyhlauncher-master-orig ttyhlauncher-master
ruslan@debian:~$ cd ttyhlauncher-master
ruslan@debian:~/ttyhlauncher-master$ qtchooser -run-tool=qmake -qt=qt5
ruslan@debian:~/ttyhlauncher-master$ make
/usr/lib/x86_64-linux-gnu/qt5/bin/uic launcherwindow.ui -o ui_launcherwindow.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic skinuploaddialog.ui -o ui_skinuploaddialog.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic settingsdialog.ui -o ui_settingsdialog.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic updatedialog.ui -o ui_updatedialog.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic feedbackdialog.ui -o ui_feedbackdialog.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic aboutdialog.ui -o ui_aboutdialog.h
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o main.o main.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o launcherwindow.o launcherwindow.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o skinuploaddialog.o skinuploaddialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o settingsdialog.o settingsdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o updatedialog.o updatedialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o feedbackdialog.o feedbackdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o aboutdialog.o aboutdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o settings.o settings.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o logger.o logger.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o util.o util.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o reply.o reply.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o downloadmanager.o downloadmanager.cpp
downloadmanager.cpp:111:65: warning: unused parameter ‘bytesTotal’ [-Wunused-parameter]
void DownloadManager::fileProgress(qint64 bytesReceived, qint64 bytesTotal) {
                                                                 ^
/usr/lib/x86_64-linux-gnu/qt5/bin/rcc -name resources resources.qrc -o qrc_resources.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o qrc_resources.o qrc_resources.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include launcherwindow.h -o moc_launcherwindow.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_launcherwindow.o moc_launcherwindow.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include skinuploaddialog.h -o moc_skinuploaddialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_skinuploaddialog.o moc_skinuploaddialog.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include settingsdialog.h -o moc_settingsdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_settingsdialog.o moc_settingsdialog.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include updatedialog.h -o moc_updatedialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_updatedialog.o moc_updatedialog.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include feedbackdialog.h -o moc_feedbackdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_feedbackdialog.o moc_feedbackdialog.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include aboutdialog.h -o moc_aboutdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_aboutdialog.o moc_aboutdialog.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include settings.h -o moc_settings.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_settings.o moc_settings.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include logger.h -o moc_logger.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_logger.o moc_logger.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include downloadmanager.h -o moc_downloadmanager.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_downloadmanager.o moc_downloadmanager.cpp
g++ -m64 -Wl,-O1 -Wl,-rpath-link,/usr/lib/x86_64-linux-gnu -o ttyhlauncher main.o launcherwindow.o skinuploaddialog.o settingsdialog.o updatedialog.o feedbackdialog.o aboutdialog.o settings.o logger.o util.o reply.o downloadmanager.o qrc_resources.o moc_launcherwindow.o moc_skinuploaddialog.o moc_settingsdialog.o moc_updatedialog.o moc_feedbackdialog.o moc_aboutdialog.o moc_settings.o moc_logger.o moc_downloadmanager.o   -L/usr/X11R6/lib64 -lquazip -lQt5WebKitWidgets -lQt5WebKit -lQt5Widgets -lQt5Network -lQt5Gui -lQt5Core -lGL -lpthread
ruslan@debian:~/ttyhlauncher-master$ ls
aboutdialog.cpp      feedbackdialog.o    logger.o                 moc_feedbackdialog.o    moc_skinuploaddialog.cpp  reply.o             settings.o            ui_launcherwindow.h    util.h
aboutdialog.h        feedbackdialog.ui   main.cpp                 moc_launcherwindow.cpp  moc_skinuploaddialog.o    resources           skinuploaddialog.cpp  ui_settingsdialog.h    util.o
aboutdialog.o        launcherwindow.cpp  main.o                   moc_launcherwindow.o    moc_updatedialog.cpp      resources.qrc       skinuploaddialog.h    ui_skinuploaddialog.h
aboutdialog.ui       launcherwindow.h    Makefile                 moc_logger.cpp          moc_updatedialog.o        settings.cpp        skinuploaddialog.o    ui_updatedialog.h
downloadmanager.cpp  launcherwindow.o    moc_aboutdialog.cpp      moc_logger.o            qrc_resources.cpp         settingsdialog.cpp  skinuploaddialog.ui   updatedialog.cpp
downloadmanager.h    launcherwindow.ui   moc_aboutdialog.o        moc_settings.cpp        qrc_resources.o           settingsdialog.h    ttyhlauncher          updatedialog.h
downloadmanager.o    LICENSE             moc_downloadmanager.cpp  moc_settingsdialog.cpp  README.md                 settingsdialog.o    ttyhlauncher.pro      updatedialog.o
feedbackdialog.cpp   logger.cpp          moc_downloadmanager.o    moc_settingsdialog.o    reply.cpp                 settingsdialog.ui   ui_aboutdialog.h      updatedialog.ui
feedbackdialog.h     logger.h            moc_feedbackdialog.cpp   moc_settings.o          reply.h                   settings.h          ui_feedbackdialog.h   util.cpp
ruslan@debian:~/ttyhlauncher-master$ ./ttyhlauncher
(18:36:26) Logger >> 03.10.14 ttyhlauncher-0.7 started.
(18:36:28) Settings >> Updating local clisent list...
(18:36:28) Util >> Make GET: http://betrok.net/ttyhstore/prefixes.json
(18:36:30) Settings >> OK. Saving local copy...
(18:36:30) Settings >> Loading local client list...
(18:36:30) Settings >> Add client: default
(18:36:30) Settings >> Add client: industrial
(18:36:30) Settings >> Updating local java keystore...
(18:36:30) Util >> Make GET: http://betrok.net/ttyhstore/store.ks
(18:36:30) Settings >> OK. Saving local copy...
(18:36:35) LauncherWindow >> Launcher window opened
Ошибка сегментирования (core dumped)
ruslan@debian:~/ttyhlauncher-master$

Также пробовал заменять LIBS += -lquazip на LIBS += -lquazip-qt5 в ttyhlauncher.pro. Результат тот же.

Вывод gdb:

Spoiler

ruslan@debian:~/ttyhlauncher-master$ gdb ./ttyhlauncher
GNU gdb (Debian 7.7.1+dfsg-3) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./ttyhlauncher...(no debugging symbols found)...done.
(gdb) run
Starting program: /home/ruslan/ttyhlauncher-master/ttyhlauncher
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffdd0f5700 (LWP 31880)]
(18:47:59) Logger >> 03.10.14 ttyhlauncher-0.7 started.
(18:48:00) Settings >> Updating local clisent list...
(18:48:00) Util >> Make GET: http://betrok.net/ttyhstore/prefixes.json
[New Thread 0x7fffd6f61700 (LWP 31985)]
[New Thread 0x7fffd5a95700 (LWP 32002)]
[New Thread 0x7fffd5294700 (LWP 32003)]
(18:48:02) Settings >> OK. Saving local copy...
[Thread 0x7fffd5a95700 (LWP 32002) exited]
(18:48:02) Settings >> Loading local client list...
(18:48:02) Settings >> Add client: default
(18:48:02) Settings >> Add client: industrial
(18:48:02) Settings >> Updating local java keystore...
(18:48:02) Util >> Make GET: http://betrok.net/ttyhstore/store.ks
[New Thread 0x7fffd5a95700 (LWP 32099)]
(18:48:02) Settings >> OK. Saving local copy...
[Thread 0x7fffd5a95700 (LWP 32099) exited]
[New Thread 0x7fffd5a95700 (LWP 32101)]
[New Thread 0x7fff87ffd700 (LWP 32161)]
[New Thread 0x7fff873fc700 (LWP 32176)]
(18:48:08) LauncherWindow >> Launcher window opened
[New Thread 0x7fff864dc700 (LWP 32283)]
[New Thread 0x7fff76c9e700 (LWP 32341)]
[New Thread 0x7fff7649d700 (LWP 32344)]

Program received signal SIGSEGV, Segmentation fault.
0x00007fff6dc6ecfc in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
(gdb) quit
A debugging session is active.

        Inferior 1 [process 31471] will be killed.

Quit anyway? (y or n) y
ruslan@debian:~/ttyhlauncher-master$

Экспериментально выяснил, что приложение не падает, если отключить связь с интернетом

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.21 (KHTML, like Gecko) konqueror/4.14.1 Safari/537.21

5 (изменено: nexfwall, 2014-10-03 18:20:37)

Re: Онтопик

ZRuslan пишет

Компилируется, но не запускается. Падает при обращении к окну мышью или клавиатурой
Ниже вывод сборки и запуска через эмулятор терминала. При сборке через QtCreator особо ничего не меняется, разве что видно, что приложение падает на return a.exec(); из main.cpp

Spoiler

ruslan@debian:~$ cp -r ttyhlauncher-master-orig ttyhlauncher-master
ruslan@debian:~$ cd ttyhlauncher-master
ruslan@debian:~/ttyhlauncher-master$ qtchooser -run-tool=qmake -qt=qt5
ruslan@debian:~/ttyhlauncher-master$ make
/usr/lib/x86_64-linux-gnu/qt5/bin/uic launcherwindow.ui -o ui_launcherwindow.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic skinuploaddialog.ui -o ui_skinuploaddialog.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic settingsdialog.ui -o ui_settingsdialog.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic updatedialog.ui -o ui_updatedialog.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic feedbackdialog.ui -o ui_feedbackdialog.h
/usr/lib/x86_64-linux-gnu/qt5/bin/uic aboutdialog.ui -o ui_aboutdialog.h
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o main.o main.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o launcherwindow.o launcherwindow.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o skinuploaddialog.o skinuploaddialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o settingsdialog.o settingsdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o updatedialog.o updatedialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o feedbackdialog.o feedbackdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o aboutdialog.o aboutdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o settings.o settings.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o logger.o logger.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o util.o util.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o reply.o reply.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o downloadmanager.o downloadmanager.cpp
downloadmanager.cpp:111:65: warning: unused parameter ‘bytesTotal’ [-Wunused-parameter]
void DownloadManager::fileProgress(qint64 bytesReceived, qint64 bytesTotal) {
                                                                 ^
/usr/lib/x86_64-linux-gnu/qt5/bin/rcc -name resources resources.qrc -o qrc_resources.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o qrc_resources.o qrc_resources.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include launcherwindow.h -o moc_launcherwindow.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_launcherwindow.o moc_launcherwindow.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include skinuploaddialog.h -o moc_skinuploaddialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_skinuploaddialog.o moc_skinuploaddialog.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include settingsdialog.h -o moc_settingsdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_settingsdialog.o moc_settingsdialog.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include updatedialog.h -o moc_updatedialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_updatedialog.o moc_updatedialog.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include feedbackdialog.h -o moc_feedbackdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_feedbackdialog.o moc_feedbackdialog.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include aboutdialog.h -o moc_aboutdialog.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_aboutdialog.o moc_aboutdialog.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include settings.h -o moc_settings.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_settings.o moc_settings.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include logger.h -o moc_logger.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_logger.o moc_logger.cpp
/usr/lib/x86_64-linux-gnu/qt5/bin/moc -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/home/ruslan/ttyhlauncher-master -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtWebKit -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/c++/4.9 -I/usr/include/x86_64-linux-gnu/c++/4.9 -I/usr/include/c++/4.9/backward -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include -I/usr/local/include -I/usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed -I/usr/include/x86_64-linux-gnu -I/usr/include downloadmanager.h -o moc_downloadmanager.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -fPIE -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WEBKIT_LIB -DQT_WIDGETS_LIB -DQT_NETWORK_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I. -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKitWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtWebKit -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtNetwork -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -I. -I. -o moc_downloadmanager.o moc_downloadmanager.cpp
g++ -m64 -Wl,-O1 -Wl,-rpath-link,/usr/lib/x86_64-linux-gnu -o ttyhlauncher main.o launcherwindow.o skinuploaddialog.o settingsdialog.o updatedialog.o feedbackdialog.o aboutdialog.o settings.o logger.o util.o reply.o downloadmanager.o qrc_resources.o moc_launcherwindow.o moc_skinuploaddialog.o moc_settingsdialog.o moc_updatedialog.o moc_feedbackdialog.o moc_aboutdialog.o moc_settings.o moc_logger.o moc_downloadmanager.o   -L/usr/X11R6/lib64 -lquazip -lQt5WebKitWidgets -lQt5WebKit -lQt5Widgets -lQt5Network -lQt5Gui -lQt5Core -lGL -lpthread
ruslan@debian:~/ttyhlauncher-master$ ls
aboutdialog.cpp      feedbackdialog.o    logger.o                 moc_feedbackdialog.o    moc_skinuploaddialog.cpp  reply.o             settings.o            ui_launcherwindow.h    util.h
aboutdialog.h        feedbackdialog.ui   main.cpp                 moc_launcherwindow.cpp  moc_skinuploaddialog.o    resources           skinuploaddialog.cpp  ui_settingsdialog.h    util.o
aboutdialog.o        launcherwindow.cpp  main.o                   moc_launcherwindow.o    moc_updatedialog.cpp      resources.qrc       skinuploaddialog.h    ui_skinuploaddialog.h
aboutdialog.ui       launcherwindow.h    Makefile                 moc_logger.cpp          moc_updatedialog.o        settings.cpp        skinuploaddialog.o    ui_updatedialog.h
downloadmanager.cpp  launcherwindow.o    moc_aboutdialog.cpp      moc_logger.o            qrc_resources.cpp         settingsdialog.cpp  skinuploaddialog.ui   updatedialog.cpp
downloadmanager.h    launcherwindow.ui   moc_aboutdialog.o        moc_settings.cpp        qrc_resources.o           settingsdialog.h    ttyhlauncher          updatedialog.h
downloadmanager.o    LICENSE             moc_downloadmanager.cpp  moc_settingsdialog.cpp  README.md                 settingsdialog.o    ttyhlauncher.pro      updatedialog.o
feedbackdialog.cpp   logger.cpp          moc_downloadmanager.o    moc_settingsdialog.o    reply.cpp                 settingsdialog.ui   ui_aboutdialog.h      updatedialog.ui
feedbackdialog.h     logger.h            moc_feedbackdialog.cpp   moc_settings.o          reply.h                   settings.h          ui_feedbackdialog.h   util.cpp
ruslan@debian:~/ttyhlauncher-master$ ./ttyhlauncher
(18:36:26) Logger >> 03.10.14 ttyhlauncher-0.7 started.
(18:36:28) Settings >> Updating local clisent list...
(18:36:28) Util >> Make GET: http://betrok.net/ttyhstore/prefixes.json
(18:36:30) Settings >> OK. Saving local copy...
(18:36:30) Settings >> Loading local client list...
(18:36:30) Settings >> Add client: default
(18:36:30) Settings >> Add client: industrial
(18:36:30) Settings >> Updating local java keystore...
(18:36:30) Util >> Make GET: http://betrok.net/ttyhstore/store.ks
(18:36:30) Settings >> OK. Saving local copy...
(18:36:35) LauncherWindow >> Launcher window opened
Ошибка сегментирования (core dumped)
ruslan@debian:~/ttyhlauncher-master$

Также пробовал заменять LIBS += -lquazip на LIBS += -lquazip-qt5 в ttyhlauncher.pro. Результат тот же.

Вывод gdb:

Spoiler

ruslan@debian:~/ttyhlauncher-master$ gdb ./ttyhlauncher
GNU gdb (Debian 7.7.1+dfsg-3) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./ttyhlauncher...(no debugging symbols found)...done.
(gdb) run
Starting program: /home/ruslan/ttyhlauncher-master/ttyhlauncher
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffdd0f5700 (LWP 31880)]
(18:47:59) Logger >> 03.10.14 ttyhlauncher-0.7 started.
(18:48:00) Settings >> Updating local clisent list...
(18:48:00) Util >> Make GET: http://betrok.net/ttyhstore/prefixes.json
[New Thread 0x7fffd6f61700 (LWP 31985)]
[New Thread 0x7fffd5a95700 (LWP 32002)]
[New Thread 0x7fffd5294700 (LWP 32003)]
(18:48:02) Settings >> OK. Saving local copy...
[Thread 0x7fffd5a95700 (LWP 32002) exited]
(18:48:02) Settings >> Loading local client list...
(18:48:02) Settings >> Add client: default
(18:48:02) Settings >> Add client: industrial
(18:48:02) Settings >> Updating local java keystore...
(18:48:02) Util >> Make GET: http://betrok.net/ttyhstore/store.ks
[New Thread 0x7fffd5a95700 (LWP 32099)]
(18:48:02) Settings >> OK. Saving local copy...
[Thread 0x7fffd5a95700 (LWP 32099) exited]
[New Thread 0x7fffd5a95700 (LWP 32101)]
[New Thread 0x7fff87ffd700 (LWP 32161)]
[New Thread 0x7fff873fc700 (LWP 32176)]
(18:48:08) LauncherWindow >> Launcher window opened
[New Thread 0x7fff864dc700 (LWP 32283)]
[New Thread 0x7fff76c9e700 (LWP 32341)]
[New Thread 0x7fff7649d700 (LWP 32344)]

Program received signal SIGSEGV, Segmentation fault.
0x00007fff6dc6ecfc in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
(gdb) quit
A debugging session is active.

        Inferior 1 [process 31471] will be killed.

Quit anyway? (y or n) y
ruslan@debian:~/ttyhlauncher-master$

Экспериментально выяснил, что приложение не падает, если отключить связь с интернетом

Когда ты заменял -lquazip на -lquazip-qt5, ты убедился, что библиотека libquazip-qt5.so.1.0.0 действительно существует? Собирал?
Да и с quazip собранным с Qt4, оно запускается, просто не распаковывает архивы.

И да, судя по gdb, не смотря на то что ты якобы запускаешь qmake из Qt5, QtGui у тебя линкует из Qt4. Qt5 != Qt4, вот и сегфолтится.

0x00007fff6dc6ecfc in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

6

Re: Онтопик

Линкуется с libQt5Gui.so.5 и почему-то одновременно с libQt5Core.so.5 и libQtCore.so.4

ruslan@debian:~/ttyhlauncher-master$ ldd ./ttyhlauncher
        linux-vdso.so.1 (0x00007fff951fc000)
        libquazip.so.1 => /usr/lib/x86_64-linux-gnu/libquazip.so.1 (0x00007f15acc32000)
        libQt5WebKitWidgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5WebKitWidgets.so.5 (0x00007f15ac9ed000)
        libQt5WebKit.so.5 => /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5 (0x00007f15aa3db000)
        libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f15a9b8c000)
        libQt5Network.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Network.so.5 (0x00007f15a9832000)
       libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f15a90fd000)
        libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f15a89c7000)
        libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007f15a867b000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f15a845d000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f15a8152000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f15a7e51000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f15a7c3a000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f15a7892000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f15a7677000)
        libQtCore.so.4 => /usr/lib/x86_64-linux-gnu/libQtCore.so.4 (0x00007f15a7188000)
        libQt5OpenGL.so.5 => /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5 (0x00007f15a6f2d000)
        libQt5PrintSupport.so.5 => /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5 (0x00007f15a6cbd000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f15a6ab4000)
        libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f15a68aa000)
        libXcomposite.so.1 => /usr/lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007f15a66a7000)
        libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f15a646c000)
        libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f15a6245000)
        libwebp.so.5 => /usr/lib/x86_64-linux-gnu/libwebp.so.5 (0x00007f15a5fe8000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f15a5ca4000)
        libxslt.so.1 => /usr/lib/x86_64-linux-gnu/libxslt.so.1 (0x00007f15a5a65000)
        libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f15a5700000)
        libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f15a53f0000)
        libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f15a519d000)
        libgstreamer-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0 (0x00007f15a4eac000)
        libgstapp-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstapp-0.10.so.0 (0x00007f15a4c9e000)
        libgstbase-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0 (0x00007f15a4a44000)
        libgstinterfaces-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstinterfaces-0.10.so.0 (0x00007f15a4831000)
        libgstpbutils-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstpbutils-0.10.so.0 (0x00007f15a460b000)
        libgstvideo-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstvideo-0.10.so.0 (0x00007f15a43ee000)
        libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f15a4129000)
        libicui18n.so.52 => /usr/lib/x86_64-linux-gnu/libicui18n.so.52 (0x00007f15a3d1c000)
        libicuuc.so.52 => /usr/lib/x86_64-linux-gnu/libicuuc.so.52 (0x00007f15a39a1000)
        libQt5Quick.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5 (0x00007f15a33e9000)
        libQt5Qml.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5 (0x00007f15a2dcb000)
        libQt5Sql.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5 (0x00007f15a2b89000)
        libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f15a2931000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f15a272d000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f15acebc000)
        libnvidia-tls.so.340.32 => /usr/lib/x86_64-linux-gnu/tls/libnvidia-tls.so.340.32 (0x00007f15a2529000)
        libnvidia-glcore.so.340.32 => /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.340.32 (0x00007f159f916000)
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f159f704000)
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f159f4e4000)
        liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f159f2c1000)
        libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f159f057000)
        libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f159ee4f000)
        libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007f159ec4b000)
        libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f159ea48000)
        liborc-0.4.so.0 => /usr/lib/x86_64-linux-gnu/liborc-0.4.so.0 (0x00007f159e7c4000)
        libicudata.so.52 => /usr/lib/x86_64-linux-gnu/libicudata.so.52 (0x00007f159cf56000)
        libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f159ccac000)
        libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f159ca8f000)
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f159c88b000)
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f159c686000

Когда ты заменял -lquazip на -lquazip-qt5, ты убедился, что библиотека libquazip-qt5.so.1.0.0 действительно существует? Собирал?

Да, существует, устанавливал, собирал, запускал
ruslan@debian:~/ttyhlauncher-master$ dpkg -l|grep quazip
ii  libquazip-dev:amd64                                         0.7-2                                 amd64        C++ wrapper wrapper for ZIP/UNZIP (development files, Qt4 build)
ii  libquazip-headers                                           0.7-2                                 amd64        C++ wrapper for ZIP/UNZIP (development header files)
ii  libquazip-qt5-1:amd64                                       0.7-2                                 amd64        C++ wrapper wrapper for ZIP/UNZIP (Qt5 build)
ii  libquazip-qt5-dev:amd64                                     0.7-2                                 amd64        C++ wrapper wrapper for ZIP/UNZIP (development files, Qt5 build)
ii  libquazip1:amd64

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.21 (KHTML, like Gecko) konqueror/4.14.1 Safari/537.21

7

Re: Онтопик

ZRuslan пишет

Линкуется с libQt5Gui.so.5 и почему-то одновременно с libQt5Core.so.5 и libQtCore.so.4

Spoiler

ruslan@debian:~/ttyhlauncher-master$ ldd ./ttyhlauncher
        linux-vdso.so.1 (0x00007fff951fc000)
        libquazip.so.1 => /usr/lib/x86_64-linux-gnu/libquazip.so.1 (0x00007f15acc32000)
        libQt5WebKitWidgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5WebKitWidgets.so.5 (0x00007f15ac9ed000)
        libQt5WebKit.so.5 => /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5 (0x00007f15aa3db000)
        libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f15a9b8c000)
        libQt5Network.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Network.so.5 (0x00007f15a9832000)
       libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f15a90fd000)
        libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f15a89c7000)
        libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007f15a867b000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f15a845d000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f15a8152000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f15a7e51000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f15a7c3a000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f15a7892000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f15a7677000)
        libQtCore.so.4 => /usr/lib/x86_64-linux-gnu/libQtCore.so.4 (0x00007f15a7188000)
        libQt5OpenGL.so.5 => /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5 (0x00007f15a6f2d000)
        libQt5PrintSupport.so.5 => /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5 (0x00007f15a6cbd000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f15a6ab4000)
        libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f15a68aa000)
        libXcomposite.so.1 => /usr/lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007f15a66a7000)
        libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f15a646c000)
        libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f15a6245000)
        libwebp.so.5 => /usr/lib/x86_64-linux-gnu/libwebp.so.5 (0x00007f15a5fe8000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f15a5ca4000)
        libxslt.so.1 => /usr/lib/x86_64-linux-gnu/libxslt.so.1 (0x00007f15a5a65000)
        libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f15a5700000)
        libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f15a53f0000)
        libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f15a519d000)
        libgstreamer-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0 (0x00007f15a4eac000)
        libgstapp-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstapp-0.10.so.0 (0x00007f15a4c9e000)
        libgstbase-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0 (0x00007f15a4a44000)
        libgstinterfaces-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstinterfaces-0.10.so.0 (0x00007f15a4831000)
        libgstpbutils-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstpbutils-0.10.so.0 (0x00007f15a460b000)
        libgstvideo-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstvideo-0.10.so.0 (0x00007f15a43ee000)
        libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f15a4129000)
        libicui18n.so.52 => /usr/lib/x86_64-linux-gnu/libicui18n.so.52 (0x00007f15a3d1c000)
        libicuuc.so.52 => /usr/lib/x86_64-linux-gnu/libicuuc.so.52 (0x00007f15a39a1000)
        libQt5Quick.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5 (0x00007f15a33e9000)
        libQt5Qml.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5 (0x00007f15a2dcb000)
        libQt5Sql.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5 (0x00007f15a2b89000)
        libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f15a2931000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f15a272d000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f15acebc000)
        libnvidia-tls.so.340.32 => /usr/lib/x86_64-linux-gnu/tls/libnvidia-tls.so.340.32 (0x00007f15a2529000)
        libnvidia-glcore.so.340.32 => /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.340.32 (0x00007f159f916000)
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f159f704000)
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f159f4e4000)
        liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f159f2c1000)
        libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f159f057000)
        libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f159ee4f000)
        libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007f159ec4b000)
        libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f159ea48000)
        liborc-0.4.so.0 => /usr/lib/x86_64-linux-gnu/liborc-0.4.so.0 (0x00007f159e7c4000)
        libicudata.so.52 => /usr/lib/x86_64-linux-gnu/libicudata.so.52 (0x00007f159cf56000)
        libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f159ccac000)
        libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f159ca8f000)
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f159c88b000)
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f159c686000

Не знаю тогда, с какого перепугу там Qt4Gui линкуется.  Разбирайся со своим дебианом сам.
OpenSUSE 13.1, УМВР

Когда ты заменял -lquazip на -lquazip-qt5, ты убедился, что библиотека libquazip-qt5.so.1.0.0 действительно существует? Собирал?

Да, существует, устанавливал, собирал, запускал

Spoiler

ruslan@debian:~/ttyhlauncher-master$ dpkg -l|grep quazip
ii  libquazip-dev:amd64                                         0.7-2                                 amd64        C++ wrapper wrapper for ZIP/UNZIP (development files, Qt4 build)
ii  libquazip-headers                                           0.7-2                                 amd64        C++ wrapper for ZIP/UNZIP (development header files)
ii  libquazip-qt5-1:amd64                                       0.7-2                                 amd64        C++ wrapper wrapper for ZIP/UNZIP (Qt5 build)
ii  libquazip-qt5-dev:amd64                                     0.7-2                                 amd64        C++ wrapper wrapper for ZIP/UNZIP (development files, Qt5 build)
ii  libquazip1:amd64

Шо, они еще и qt5 версию поставляют? Молодцы. Линкуй тогда её.

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

8 (изменено: ZAGNU, 2014-10-03 23:00:23)

Re: Онтопик

В момент подключения к серверу выдаёт пустой еррор с заголовком "У нас п...". Релевантный лог:

(23:40:54) LauncherWindow >> Try to start game...
(23:40:54) LauncherWindow >> Client id: default
(23:40:54) LauncherWindow >> Online mode is selected
(23:40:54) LauncherWindow >> Making login request...
(23:40:54) Util >> Make POST: https://master.ttyh.ru/index.php?act=login
(23:41:04) LauncherWindow >> Error:

Информативно, да. Я так и не смог объяснить кутикреатору, что мне нужен qt5 для сборки, иначе было бы подробней.

Upd. Оффлайн игра выдаёт следующее:

(23:53:50) LauncherWindow >> Try to launch game...
(23:53:50) LauncherWindow >> Main window hidden
(23:53:51) Client >> Exception in thread "main" (23:53:51) Client >> java.lang.NoClassDefFoundError: joptsimple/OptionSpec(23:53:51) Client >> 
(23:53:51) Client >>    at java.lang.Class.getDeclaredMethods0(Native Method)(23:53:51) Client >> 
(23:53:51) Client >>    at java.lang.Class.privateGetDeclaredMethods(Class.java:2531)(23:53:51) Client >> 
(23:53:51) Client >>    at java.lang.Class.getMethod0(Class.java:2774)(23:53:51) Client >> 
(23:53:51) Client >>    at java.lang.Class.getMethod(Class.java:1663)(23:53:51) Client >> 
(23:53:51) Client >>    at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:494)(23:53:51) Client >> 
(23:53:51) Client >>    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:486)(23:53:51) Client >> 
(23:53:51) Client >> Caused by: java.lang.ClassNotFoundException: joptsimple.OptionSpec(23:53:51) Client >> 
(23:53:51) Client >>    at java.net.URLClassLoader$1.run(URLClassLoader.java:366)(23:53:51) Client >> 
(23:53:51) Client >>    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)(23:53:51) Client >> 
(23:53:51) Client >>    at java.security.AccessController.doPrivileged(Native Method)(23:53:51) Client >> 
(23:53:51) Client >>    at java.net.URLClassLoader.findClass(URLClassLoader.java:354)(23:53:51) Client >> 
(23:53:51) Client >>    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)(23:53:51) Client >> 
(23:53:51) Client >>    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)(23:53:51) Client >> 
(23:53:51) Client >>    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)(23:53:51) Client >> 
(23:53:51) Client >>    ... 6 more(23:53:51) Client >> 
(23:53:51) LauncherWindow >> Game process finished!
(23:53:55) LauncherWindow >> Error: not null game exit code: 1
(23:53:55) LauncherWindow >> Main window showed

И, аналогично вышеописанному случаю,
libQtCore.so.4 => /usr/lib64/qt4/libQtCore.so.4 (0x0000003e5e800000)
libQt5Core.so.5 => /usr/lib64/libQt5Core.so.5 (0x00007f2fee7e5000)

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

9 (изменено: Zenitur, 2014-10-04 02:23:32)

Re: Онтопик

(05:40:04) LauncherWindow >> Try to launch game...
(05:40:04) LauncherWindow >> Main window hidden
(05:40:05) Client >> 2014-10-04 05:40:05,750 ERROR Error processing element Queue: CLASS_NOT_FOUND
(05:40:05) Client >> 2014-10-04 05:40:05,879 ERROR Unable to locate appender ServerGuiConsole for logger 
(05:40:05) Client >> Exception in thread "main" java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path(05:40:05) Client >> 
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)(05:40:05) Client >> 
    at java.lang.System.loadLibrary(Unknown Source)(05:40:05) Client >> 
(05:40:05) Client >>     at org.lwjgl.Sys$1.run(Sys.java:73)(05:40:05) Client >> 
(05:40:05) Client >>     at java.security.AccessController.doPrivileged(Native Method)
(05:40:05) Client >>     at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
(05:40:05) Client >>     at org.lwjgl.Sys.loadLibrary(Sys.java:95)
    at org.lwjgl.Sys.<clinit>(Sys.java:112)
(05:40:05) Client >>     at bao.K(SourceFile:2173)
(05:40:05) Client >>     at net.minecraft.client.main.Main.main(SourceFile:72)
(05:40:06) LauncherWindow >> Game process finished!
(05:40:07) LauncherWindow >> Error: not null game exit code: 1
(05:40:07) LauncherWindow >> Main window showed

Пробовал OpenJDK7 и Oracle Java 7. Пробовал копировать библиотеки из лицензионного клиента с заменой файлов.

UPD: Параметр "-Djava.library.path=/home/zenitur/lwjgl-2.9.1/native/linux" не помог

UPD: Помогло обновление quazip с 0.5.1 до 0.7.

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.120 Safari/537.36

10

Re: Онтопик

То что у вас линкуется QtGui-4 очень странно, вот как слинковано у меня. Тоже дебиан:

ldd ttyhlauncher
        linux-vdso.so.1 (0x00007fff4a5dd000)
        libquazip.so.1 => /usr/local/lib/libquazip.so.1 (0x00007ff846e9c000)
        libQt5WebKitWidgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5WebKitWidgets.so.5 (0x00007ff846c57000)
        libQt5Quick.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5 (0x00007ff84669e000)
        libQt5OpenGL.so.5 => /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5 (0x00007ff846443000)
        libQt5PrintSupport.so.5 => /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5 (0x00007ff8461d3000)
        libQt5WebKit.so.5 => /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5 (0x00007ff843bc1000)
        libQt5Qml.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5 (0x00007ff8435a4000)
        libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007ff842d55000)
        libQt5Network.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Network.so.5 (0x00007ff8429fa000)
        libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007ff8422c6000)
        libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007ff841b90000)

        libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007ff841843000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007ff841626000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007ff84131b000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007ff841019000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007ff840e03000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007ff840a5b000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007ff840852000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007ff840637000)
        libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007ff84042c000)
        libXcomposite.so.1 => /usr/lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007ff840229000)
        libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007ff83ffef000)
        libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007ff83fdc7000)
        libwebp.so.5 => /usr/lib/x86_64-linux-gnu/libwebp.so.5 (0x00007ff83fb6a000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007ff83f827000)
        libxslt.so.1 => /usr/lib/x86_64-linux-gnu/libxslt.so.1 (0x00007ff83f5e7000)
        libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007ff83f282000)
        libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007ff83ef73000)
        libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007ff83ed1f000)
        libgstreamer-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0 (0x00007ff83ea2e000)
        libgstapp-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstapp-0.10.so.0 (0x00007ff83e821000)
        libgstbase-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0 (0x00007ff83e5c6000)
        libgstinterfaces-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstinterfaces-0.10.so.0 (0x00007ff83e3b3000)
        libgstpbutils-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstpbutils-0.10.so.0 (0x00007ff83e18e000)
        libgstvideo-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstvideo-0.10.so.0 (0x00007ff83df70000)
        libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007ff83dcab000)
        libicui18n.so.52 => /usr/lib/x86_64-linux-gnu/libicui18n.so.52 (0x00007ff83d89f000)
        libicuuc.so.52 => /usr/lib/x86_64-linux-gnu/libicuuc.so.52 (0x00007ff83d523000)
        libQt5Sql.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5 (0x00007ff83d2e1000)                                                                                                                                                     
        libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007ff83d089000)                                                                                                                                                 
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007ff83ce85000)                                                                                                                                                                 
        /lib64/ld-linux-x86-64.so.2 (0x00007ff8470f3000)                                                                                                                                                                                     
        libnvidia-tls.so.340.32 => /usr/lib/x86_64-linux-gnu/tls/libnvidia-tls.so.340.32 (0x00007ff83cc81000)                                                                                                                               
        libnvidia-glcore.so.340.32 => /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.340.32 (0x00007ff83a06e000)                                                                                                                             
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007ff839e5c000)                                                                                                                                                         
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007ff839c3c000)                                                                                                                                                           
        liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007ff839a19000)                                                                                                                                                             
        libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007ff8397af000)                                                                                                                                                             
        libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007ff8395a7000)                                                                                                                                                           
        libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007ff8393a3000)                                                                                                                                           
        libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007ff8391a0000)                                                                                                                                           
        liborc-0.4.so.0 => /usr/lib/x86_64-linux-gnu/liborc-0.4.so.0 (0x00007ff838f1c000)                                                                                                                                                   
        libicudata.so.52 => /usr/lib/x86_64-linux-gnu/libicudata.so.52 (0x00007ff8376ae000)                                                                                                                                                 
        libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007ff837404000)                                                                                                                                                 
        libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007ff8371e7000)                                                                                                                                               
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007ff836fe3000)                                                                                                                                                           
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007ff836dde000)

libquazip собирал из сорцов с поддержкой qt-5. Если libquazip собрана со старой версией qt, то у вас возникнут проблемы с распаковкой библиотек и следовательно, запуском игры. Очевидно, не подхватится lwjgl:

java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.1.0

11

Re: Онтопик

Ещё мысли по поводу линковки с QtGui-4. Возможно ты ранее прогнал MOC из 4 версии и он сгенерировал что-то не так.

Почисти катоалог сборки, запусти qmake, а затем make.

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.1.0

12 (изменено: nexfwall, 2014-10-04 11:54:05)

Re: Онтопик

Zenitur пишет
Spoiler
(05:40:04) LauncherWindow >> Try to launch game...
(05:40:04) LauncherWindow >> Main window hidden
(05:40:05) Client >> 2014-10-04 05:40:05,750 ERROR Error processing element Queue: CLASS_NOT_FOUND
(05:40:05) Client >> 2014-10-04 05:40:05,879 ERROR Unable to locate appender ServerGuiConsole for logger 
(05:40:05) Client >> Exception in thread "main" java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path(05:40:05) Client >> 
    at java.lang.ClassLoader.loadLibrary(Unknown Source)
    at java.lang.Runtime.loadLibrary0(Unknown Source)(05:40:05) Client >> 
    at java.lang.System.loadLibrary(Unknown Source)(05:40:05) Client >> 
(05:40:05) Client >>     at org.lwjgl.Sys$1.run(Sys.java:73)(05:40:05) Client >> 
(05:40:05) Client >>     at java.security.AccessController.doPrivileged(Native Method)
(05:40:05) Client >>     at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
(05:40:05) Client >>     at org.lwjgl.Sys.loadLibrary(Sys.java:95)
    at org.lwjgl.Sys.<clinit>(Sys.java:112)
(05:40:05) Client >>     at bao.K(SourceFile:2173)
(05:40:05) Client >>     at net.minecraft.client.main.Main.main(SourceFile:72)
(05:40:06) LauncherWindow >> Game process finished!
(05:40:07) LauncherWindow >> Error: not null game exit code: 1
(05:40:07) LauncherWindow >> Main window showed

Пробовал OpenJDK7 и Oracle Java 7. Пробовал копировать библиотеки из лицензионного клиента с заменой файлов.

UPD: Параметр "-Djava.library.path=/home/zenitur/lwjgl-2.9.1/native/linux" не помог

UPD: Помогло обновление quazip с 0.5.1 до 0.7.

Еще можно было просто собрать quazip под qt5...

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

13

Re: Онтопик

Да, влинковываются qt4 и qt5 одновременно, если quazip с qt4 собран. Исправил.

Но моя проблема с нестартующей жабой остаётся: java.lang.NoClassDefFoundError в сингле, пустая ошибка при заходе на сервер. Это может быть связано с тем, что я не делал make install, а просто make? И запускаю программу из сборочного каталога. Ведь не должно.

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

14 (изменено: nexfwall, 2014-10-04 12:29:10)

Re: Онтопик

ZAGNU пишет

Да, влинковываются qt4 и qt5 одновременно, если quazip с qt4 собран. Исправил.

Но моя проблема с нестартующей жабой остаётся: java.lang.NoClassDefFoundError в сингле, пустая ошибка при заходе на сервер. Это может быть связано с тем, что я не делал make install, а просто make? И запускаю программу из сборочного каталога. Ведь не должно.

Короче, все дебианщики, пробуйте так. Нужно знать, где вы дебианщики расходитесь с нормальными дистрибутивами. :D Я так и собираю лончер под SUSE:

  • Убедитесь, что установлены пакеты (аналогичные деб-названия сами придумайте) libqt5-qtbase-devel >= 5.3, libQt5WebKitWidgets-devel >= 5.3, quazip-devel

  • Убедитесь, что у вас вообще установлен Qt5 >= 5.3, потому что это зависимость. Главная зависимость. Может вы с Qt 5.1 собираете?

  • Убедитесь, что установлены следующие компоненты Qt5: libQt5Core5, libQt5Gui5, libQt5WebKitWidgets5, libQt5Widgets5, libQt5Network5.

  • Убедитесь, что вы запускаете qmake именно от Qt5. Проверьте Makefile после его генерации на всякую ересь, вроде линковки с Qt4. Да, оно не должно быть с qmake от Qt5, но а вдруг в вашем дебиане кривой qmake?

  • Убедитесь, что вы линкуете qt5-версию quazip. Падать оно не будет, но и архивы распаковывать не будет. Вот тебе и "ненайденный lwjgl".

  • После make, убедитесь с помощью ldd, что всякая ересь не слинкована.

Больше я не знаю что делать с вашим дебианом. Мне что, его в виртуалку поставить, и собрать вам назло без кривоты? Подумайте, что вы делаете не так.

ZAGNU пишет

Это может быть связано с тем, что я не делал make install, а просто make? И запускаю программу из сборочного каталога. Ведь не должно.

Нет, make install для запуска не нужен.

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

15

Re: Онтопик

Это не проблема лаунчера вообще.

java -cp /home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/client_default/versions/1.7.10/1.7.10.jar net.minecraft.client.main.Main
Exception in thread "main" java.lang.NoClassDefFoundError: joptsimple/OptionSpec
        at java.lang.Class.getDeclaredMethods0(Native Method)
        at java.lang.Class.privateGetDeclaredMethods(Class.java:2570)
        at java.lang.Class.getMethod0(Class.java:2813)
        at java.lang.Class.getMethod(Class.java:1663)
        at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:494)
        at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:486)
Caused by: java.lang.ClassNotFoundException: joptsimple.OptionSpec
        at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
        ... 6 more
$ java -version
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

ЧЯДНТ?

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

16 (изменено: nexfwall, 2014-10-04 13:00:14)

Re: Онтопик

ZAGNU пишет

Это не проблема лаунчера вообще.

Spoiler
java -cp /home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/client_default/versions/1.7.10/1.7.10.jar net.minecraft.client.main.Main
Exception in thread "main" java.lang.NoClassDefFoundError: joptsimple/OptionSpec
        at java.lang.Class.getDeclaredMethods0(Native Method)
        at java.lang.Class.privateGetDeclaredMethods(Class.java:2570)
        at java.lang.Class.getMethod0(Class.java:2813)
        at java.lang.Class.getMethod(Class.java:1663)
        at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:494)
        at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:486)
Caused by: java.lang.ClassNotFoundException: joptsimple.OptionSpec
        at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
        ... 6 more
$ java -version
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

ЧЯДНТ?

Перед вызовом главного класса ты забыл указать целую тонну библиотек-зависимостей, которые требует Minecraft для запуска, чтобы жаба их подгрузила. Потому что Minecraft этого больше не делает, еще с 1.6 версии. А ты не знал? Для того лаунчер и нужен теперь.

Так что не выёживайся, и запускай через лаунчер. А потом пости сюда то, что он написал.

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

17

Re: Онтопик

А потом пости сюда то, что он написал.

Он написал

Run string: java -Djavax.net.ssl.trustStore=/home/krovavii_abort_bez_narkoza_pitki/.config/ttyhlauncher/keystore.ks -Djavax.net.ssl.trustStorePassword=123456 -Djava.library.path=/home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/client_default/natives -cp /home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/client_default/versions/1.7.10/1.7.10.jar net.minecraft.client.main.Main --username dsfsdfsd --version 1.7.10 --gameDir /home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/client_default/prefixes/1.7.10 --assetsDir /home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/assets --assetIndex 1.7.10 --uuid HARD --accessToken CORE --userProperties {} --userType mojang

А ответ жабы был точно такой же.

Exception (13:41:20) Client >> in thread "main" (13:41:20) Client >> java.lang.NoClassDefFoundError: joptsimple/OptionSpec

Зачем платить больше?

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

18 (изменено: nexfwall, 2014-10-04 15:23:56)

Re: Онтопик

ZAGNU пишет

А потом пости сюда то, что он написал.

Он написал

Spoiler
Run string: java -Djavax.net.ssl.trustStore=/home/krovavii_abort_bez_narkoza_pitki/.config/ttyhlauncher/keystore.ks -Djavax.net.ssl.trustStorePassword=123456 -Djava.library.path=/home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/client_default/natives -cp /home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/client_default/versions/1.7.10/1.7.10.jar net.minecraft.client.main.Main --username dsfsdfsd --version 1.7.10 --gameDir /home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/client_default/prefixes/1.7.10 --assetsDir /home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/assets --assetIndex 1.7.10 --uuid HARD --accessToken CORE --userProperties {} --userType mojang

А ответ жабы был точно такой же.

Exception (13:41:20) Client >> in thread "main" (13:41:20) Client >> java.lang.NoClassDefFoundError: joptsimple/OptionSpec

Зачем платить больше?

Spoiler
(14:14:44) LauncherWindow >> Run string: java -Djavax.net.ssl.trustStore=/home/nexfwall/.config/ttyhlauncher/keystore.ks -Djavax.net.ssl.trustStorePassword=123456 -Djava.library.path=/home/nexfwall/.local/share/ttyh_minecraft/client_default/natives -cp /home/nexfwall/.local/share/ttyh_minecraft/libraries/com/mojang/realms/1.3.5/realms-1.3.5.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/org/apache/commons/commons-compress/1.8.1/commons-compress-1.8.1.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/commons-logging/commons-logging/1.1.3/commons-logging-1.1.3.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/org/apache/httpcomponents/httpcore/4.3.2/httpcore-4.3.2.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/java3d/vecmath/1.3.1/vecmath-1.3.1.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/net/sf/trove4j/trove4j/3.0.3/trove4j-3.0.3.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/com/ibm/icu/icu4j-core-mojang/51.2/icu4j-core-mojang-51.2.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/net/sf/jopt-simple/jopt-simple/4.5/jopt-simple-4.5.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/com/paulscode/codecjorbis/20101023/codecjorbis-20101023.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/com/paulscode/codecwav/20101023/codecwav-20101023.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/com/paulscode/libraryjavasound/20101123/libraryjavasound-20101123.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/com/paulscode/librarylwjglopenal/20100824/librarylwjglopenal-20100824.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/com/paulscode/soundsystem/20120107/soundsystem-20120107.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/io/netty/netty-all/4.0.10.Final/netty-all-4.0.10.Final.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/com/google/guava/guava/15.0/guava-15.0.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/org/apache/commons/commons-lang3/3.1/commons-lang3-3.1.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/commons-io/commons-io/2.4/commons-io-2.4.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/commons-codec/commons-codec/1.9/commons-codec-1.9.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/com/google/code/gson/gson/2.2.4/gson-2.2.4.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/com/mojang/authlib/1.5.16/authlib-1.5.16.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/org/apache/logging/log4j/log4j-api/2.0-beta9/log4j-api-2.0-beta9.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/org/apache/logging/log4j/log4j-core/2.0-beta9/log4j-core-2.0-beta9.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/org/lwjgl/lwjgl/lwjgl/2.9.1/lwjgl-2.9.1.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/org/lwjgl/lwjgl/lwjgl_util/2.9.1/lwjgl_util-2.9.1.jar:/home/nexfwall/.local/share/ttyh_minecraft/libraries/tv/twitch/twitch/5.16/twitch-5.16.jar:/home/nexfwall/.local/share/ttyh_minecraft/client_default/versions/1.7.10/1.7.10.jar net.minecraft.client.main.Main --username nexfwall --version 1.7.10 --gameDir /home/nexfwall/.local/share/ttyh_minecraft/client_default/prefixes/1.7.10 --assetsDir /home/nexfwall/.local/share/ttyh_minecraft/assets --assetIndex 1.7.10 --uuid blah --accessToken blah --userProperties {} --userType mojang

У тебя неправильно генерируется run string. Это к Figec.

//И причём, скомпилировал, и напустил только что. Потому что пакет пока не готов. ЧЯДНТ?

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

19

Re: Онтопик

Похоже, я зря не выложил раньше свой лдд. В нём на 10 ентрей меньше, чем у вас.

ldd ttyhlauncher
        linux-vdso.so.1 (0x00007fff62f8c000)
        libquazip.so.1 => /usr/lib64/libquazip.so.1 (0x00007f58c6299000)
        libQt5WebKitWidgets.so.5 => /usr/lib64/libQt5WebKitWidgets.so.5 (0x00007f58c6055000)
        libQt5Widgets.so.5 => /usr/lib64/libQt5Widgets.so.5 (0x00007f58c580c000)
        libQt5WebKit.so.5 => /usr/lib64/libQt5WebKit.so.5 (0x00007f58c33af000)
        libQt5Gui.so.5 => /usr/lib64/libQt5Gui.so.5 (0x00007f58c2cad000)
        libQt5Network.so.5 => /usr/lib64/libQt5Network.so.5 (0x00000033e1a00000)
        libQt5Core.so.5 => /usr/lib64/libQt5Core.so.5 (0x00000033e1200000)
        libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007f58c2960000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003e58c00000)
        libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/libstdc++.so.6 (0x0000003e66400000)
        libm.so.6 => /lib64/libm.so.6 (0x0000003e59800000)
        libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/libgcc_s.so.1 (0x0000003e66800000)
        libc.so.6 => /lib64/libc.so.6 (0x0000003e58800000)
        libz.so.1 => /lib64/libz.so.1 (0x0000003e59400000)
        libQt5Sensors.so.5 => /usr/lib64/libQt5Sensors.so.5 (0x00000033e4600000)
        libQt5OpenGL.so.5 => /usr/lib64/libQt5OpenGL.so.5 (0x00007f58c2703000)
        librt.so.1 => /lib64/librt.so.1 (0x0000003e59c00000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x0000003666600000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x0000003668a00000)
        libjpeg.so.62 => /usr/lib64/libjpeg.so.62 (0x0000003e69a00000)
        libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x0000003e5b800000)
        libwebp.so.5 => /usr/lib64/libwebp.so.5 (0x00000033e7400000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x0000003664200000)
        libsqlite3.so.0 => /usr/lib64/libsqlite3.so.0 (0x0000003e61000000)
        libicui18n.so.52 => /usr/lib64/libicui18n.so.52 (0x000000323d400000)
        libicuuc.so.52 => /usr/lib64/libicuuc.so.52 (0x0000003e67000000)
        libQt5Positioning.so.5 => /usr/lib64/libQt5Positioning.so.5 (0x00000033e4200000)
        libQt5Quick.so.5 => /usr/lib64/libQt5Quick.so.5 (0x00007f58c213b000)
        libQt5Qml.so.5 => /usr/lib64/libQt5Qml.so.5 (0x00000033e2600000)
        libQt5Sql.so.5 => /usr/lib64/libQt5Sql.so.5 (0x00000033e3e00000)
        libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0 (0x0000003669200000)
        libssl.so.1.0.0 => /usr/lib64/libssl.so.1.0.0 (0x0000003e5f800000)
        libcrypto.so.1.0.0 => /usr/lib64/libcrypto.so.1.0.0 (0x0000003e5fc00000)
        libpcre16.so.0 => /usr/lib64/libpcre16.so.0 (0x00000033e0e00000)
        libdl.so.2 => /lib64/libdl.so.2 (0x0000003e59000000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x0000003e5a000000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003e58400000)
        libnvidia-tls.so.340.24 => /usr/lib64/libnvidia-tls.so.340.24 (0x00007f58c1f35000)
        libnvidia-glcore.so.340.24 => /usr/lib64/libnvidia-glcore.so.340.24 (0x00007f58bf321000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x0000003664a00000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x0000003664600000)
        libicudata.so.52 => /usr/lib64/libicudata.so.52 (0x0000003e68000000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x0000003e5c000000)
        libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3 (0x0000003e64400000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x0000003e5a800000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x0000003e5ac00000)
        libbz2.so.1 => /lib64/libbz2.so.1 (0x0000003e5a400000)

И теперь плавно встаёт вопрос, почему линковщик не матерится при сборке.

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

20

Re: Онтопик

ZAGNU пишет

Похоже, я зря не выложил раньше свой лдд. В нём на 10 ентрей меньше, чем у вас.

Spoiler
ldd ttyhlauncher
        linux-vdso.so.1 (0x00007fff62f8c000)
        libquazip.so.1 => /usr/lib64/libquazip.so.1 (0x00007f58c6299000)
        libQt5WebKitWidgets.so.5 => /usr/lib64/libQt5WebKitWidgets.so.5 (0x00007f58c6055000)
        libQt5Widgets.so.5 => /usr/lib64/libQt5Widgets.so.5 (0x00007f58c580c000)
        libQt5WebKit.so.5 => /usr/lib64/libQt5WebKit.so.5 (0x00007f58c33af000)
        libQt5Gui.so.5 => /usr/lib64/libQt5Gui.so.5 (0x00007f58c2cad000)
        libQt5Network.so.5 => /usr/lib64/libQt5Network.so.5 (0x00000033e1a00000)
        libQt5Core.so.5 => /usr/lib64/libQt5Core.so.5 (0x00000033e1200000)
        libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007f58c2960000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003e58c00000)
        libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/libstdc++.so.6 (0x0000003e66400000)
        libm.so.6 => /lib64/libm.so.6 (0x0000003e59800000)
        libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/libgcc_s.so.1 (0x0000003e66800000)
        libc.so.6 => /lib64/libc.so.6 (0x0000003e58800000)
        libz.so.1 => /lib64/libz.so.1 (0x0000003e59400000)
        libQt5Sensors.so.5 => /usr/lib64/libQt5Sensors.so.5 (0x00000033e4600000)
        libQt5OpenGL.so.5 => /usr/lib64/libQt5OpenGL.so.5 (0x00007f58c2703000)
        librt.so.1 => /lib64/librt.so.1 (0x0000003e59c00000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x0000003666600000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x0000003668a00000)
        libjpeg.so.62 => /usr/lib64/libjpeg.so.62 (0x0000003e69a00000)
        libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x0000003e5b800000)
        libwebp.so.5 => /usr/lib64/libwebp.so.5 (0x00000033e7400000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x0000003664200000)
        libsqlite3.so.0 => /usr/lib64/libsqlite3.so.0 (0x0000003e61000000)
        libicui18n.so.52 => /usr/lib64/libicui18n.so.52 (0x000000323d400000)
        libicuuc.so.52 => /usr/lib64/libicuuc.so.52 (0x0000003e67000000)
        libQt5Positioning.so.5 => /usr/lib64/libQt5Positioning.so.5 (0x00000033e4200000)
        libQt5Quick.so.5 => /usr/lib64/libQt5Quick.so.5 (0x00007f58c213b000)
        libQt5Qml.so.5 => /usr/lib64/libQt5Qml.so.5 (0x00000033e2600000)
        libQt5Sql.so.5 => /usr/lib64/libQt5Sql.so.5 (0x00000033e3e00000)
        libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0 (0x0000003669200000)
        libssl.so.1.0.0 => /usr/lib64/libssl.so.1.0.0 (0x0000003e5f800000)
        libcrypto.so.1.0.0 => /usr/lib64/libcrypto.so.1.0.0 (0x0000003e5fc00000)
        libpcre16.so.0 => /usr/lib64/libpcre16.so.0 (0x00000033e0e00000)
        libdl.so.2 => /lib64/libdl.so.2 (0x0000003e59000000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x0000003e5a000000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003e58400000)
        libnvidia-tls.so.340.24 => /usr/lib64/libnvidia-tls.so.340.24 (0x00007f58c1f35000)
        libnvidia-glcore.so.340.24 => /usr/lib64/libnvidia-glcore.so.340.24 (0x00007f58bf321000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x0000003664a00000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x0000003664600000)
        libicudata.so.52 => /usr/lib64/libicudata.so.52 (0x0000003e68000000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x0000003e5c000000)
        libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3 (0x0000003e64400000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x0000003e5a800000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x0000003e5ac00000)
        libbz2.so.1 => /lib64/libbz2.so.1 (0x0000003e5a400000)

И теперь плавно встаёт вопрос, почему линковщик не матерится при сборке.

Для сравнения, мой ldd:

Spoiler
nexfwall@VPCYB1S1R-LS03:~/Build/ttyhlauncher/build> ldd ttyhlauncher
        linux-vdso.so.1 (0x00007fff26dfe000)
        libquazip-qt5.so.1 => /usr/lib64/libquazip-qt5.so.1 (0x00007f7ae8685000)
        libQt5WebKitWidgets.so.5 => /usr/lib64/libQt5WebKitWidgets.so.5 (0x00007f7ae8440000)
        libQt5WebKit.so.5 => /usr/lib64/libQt5WebKit.so.5 (0x00007f7ae5ebc000)
        libQt5Widgets.so.5 => /usr/lib64/libQt5Widgets.so.5 (0x00007f7ae5686000)
        libQt5Network.so.5 => /usr/lib64/libQt5Network.so.5 (0x00007f7ae5335000)
        libQt5Gui.so.5 => /usr/lib64/libQt5Gui.so.5 (0x00007f7ae4c26000)
        libQt5Core.so.5 => /usr/lib64/libQt5Core.so.5 (0x00007f7ae4560000)
        libGL.so.1 => /usr/X11R6/lib64/libGL.so.1 (0x00007f7ae437e000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f7ae4160000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f7ae3e58000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f7ae3b55000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f7ae393e000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f7ae3590000)
        libQt5OpenGL.so.5 => /usr/lib64/libQt5OpenGL.so.5 (0x00007f7ae3334000)
        libQt5PrintSupport.so.5 => /usr/lib64/libQt5PrintSupport.so.5 (0x00007f7ae30c4000)
        libQt5Sensors.so.5 => /usr/lib64/libQt5Sensors.so.5 (0x00007f7ae2e85000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f7ae2c7d000)
        libz.so.1 => /lib64/libz.so.1 (0x00007f7ae2a67000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f7ae285d000)
        libXcomposite.so.1 => /usr/lib64/libXcomposite.so.1 (0x00007f7ae265a000)
        libjpeg.so.8 => /usr/lib64/libjpeg.so.8 (0x00007f7ae2409000)
        libpng16.so.16 => /usr/lib64/libpng16.so.16 (0x00007f7ae21cc000)
        libwebp.so.4 => /usr/lib64/libwebp.so.4 (0x00007f7ae1f7b000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f7ae1c3d000)
        libxslt.so.1 => /usr/lib64/libxslt.so.1 (0x00007f7ae19fe000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007f7ae1693000)
        libglib-2.0.so.0 => /usr/lib64/libglib-2.0.so.0 (0x00007f7ae1390000)
        libgobject-2.0.so.0 => /usr/lib64/libgobject-2.0.so.0 (0x00007f7ae113f000)
        libgstreamer-0.10.so.0 => /usr/lib64/libgstreamer-0.10.so.0 (0x00007f7ae0e53000)
        libgstapp-0.10.so.0 => /usr/lib64/libgstapp-0.10.so.0 (0x00007f7ae0c46000)
        libgstbase-0.10.so.0 => /usr/lib64/libgstbase-0.10.so.0 (0x00007f7ae09f1000)
        libgstinterfaces-0.10.so.0 => /usr/lib64/libgstinterfaces-0.10.so.0 (0x00007f7ae07df000)
        libgstpbutils-0.10.so.0 => /usr/lib64/libgstpbutils-0.10.so.0 (0x00007f7ae05bb000)                                                                                                                                      
        libgstvideo-0.10.so.0 => /usr/lib64/libgstvideo-0.10.so.0 (0x00007f7ae039f000)                                                                                                                                          
        libsqlite3.so.0 => /usr/lib64/libsqlite3.so.0 (0x00007f7ae00ec000)                                                                                                                                                      
        libicui18n.so.51.2 => /usr/lib64/libicui18n.so.51.2 (0x00007f7adfcdb000)                                                                                                                                                
        libicuuc.so.51.2 => /usr/lib64/libicuuc.so.51.2 (0x00007f7adf95e000)                                                                                                                                                    
        libQt5Quick.so.5 => /usr/lib64/libQt5Quick.so.5 (0x00007f7adf3aa000)                                                                                                                                                    
        libQt5Qml.so.5 => /usr/lib64/libQt5Qml.so.5 (0x00007f7aded93000)                                                                                                                                                        
        libQt5Sql.so.5 => /usr/lib64/libQt5Sql.so.5 (0x00007f7adeb52000)                                                                                                                                                        
        libQt5Positioning.so.5 => /usr/lib64/libQt5Positioning.so.5 (0x00007f7ade919000)                                                                                                                                        
        libssl.so.1.0.0 => /lib64/libssl.so.1.0.0 (0x00007f7ade6b2000)                                                                                                                                                          
        libcrypto.so.1.0.0 => /lib64/libcrypto.so.1.0.0 (0x00007f7ade2c7000)                                                                                                                                                    
        libharfbuzz.so.0 => /usr/lib64/libharfbuzz.so.0 (0x00007f7ade074000)                                                                                                                                                    
        libpcre16.so.0 => /usr/lib64/libpcre16.so.0 (0x00007f7adde17000)                                                                                                                                                        
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f7addc13000)                                                                                                                                                                    
        /lib64/ld-linux-x86-64.so.2 (0x00007f7ae88ad000)                                                                                                                                                                        
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f7adda01000)                                                                                                                                                            
        libatiuki.so.1 => /usr/lib64/libatiuki.so.1 (0x00007f7ae8970000)                                                                                                                                                        
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f7add7e2000)                                                                                                                                                              
        liblzma.so.5 => /usr/lib64/liblzma.so.5 (0x00007f7add5bc000)                                                                                                                                                            
        libpcre.so.1 => /usr/lib64/libpcre.so.1 (0x00007f7add356000)                                                                                                                                                            
        libffi.so.4 => /usr/lib64/libffi.so.4 (0x00007f7add14e000)                                                                                                                                                              
        libgmodule-2.0.so.0 => /usr/lib64/libgmodule-2.0.so.0 (0x00007f7adcf4a000)
        liborc-0.4.so.0 => /usr/lib64/liborc-0.4.so.0 (0x00007f7adccc7000)
        libicudata.so.51.2 => /usr/lib64/libicudata.so.51.2 (0x00007f7adcac6000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f7adc834000)
        libgraphite2.so.3 => /usr/lib64/libgraphite2.so.3 (0x00007f7adc618000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f7adc414000)
Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

21

Re: Онтопик

Некс, меняй пароль.

Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0

22 (изменено: nexfwall, 2014-10-04 15:25:20)

Re: Онтопик

ZAGNU пишет

Некс, меняй пароль.

Что за провокационные заявления?

//Я AccessToken запалил, да.

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

23

Re: Онтопик

ZAGNU пишет

Это не проблема лаунчера вообще.

java -cp /home/krovavii_abort_bez_narkoza_pitki/.local/share/ttyh_minecraft/client_default/versions/1.7.10/1.7.10.jar net.minecraft.client.main.Main
Exception in thread "main" java.lang.NoClassDefFoundError: joptsimple/OptionSpec
        at java.lang.Class.getDeclaredMethods0(Native Method)
        at java.lang.Class.privateGetDeclaredMethods(Class.java:2570)
        at java.lang.Class.getMethod0(Class.java:2813)
        at java.lang.Class.getMethod(Class.java:1663)
        at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:494)
        at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:486)
Caused by: java.lang.ClassNotFoundException: joptsimple.OptionSpec
        at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
        ... 6 more
$ java -version
java version "1.7.0_67"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

ЧЯДНТ?

Выложи куда-нить весь лог запуска. У тебя будто бы пустой класспатч.

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.1.0

24 (изменено: nexfwall, 2014-10-04 15:35:35)

Re: Онтопик

Figec пишет

Выложи куда-нить весь лог запуска. У тебя будто бы пустой класспатч.

//Можешь посмотреть мой пулл реквест сейчас?

Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

25

Re: Онтопик

nexfwall пишет

Короче, все дебианщики, пробуйте так. Нужно знать, где вы дебианщики расходитесь с нормальными дистрибутивами. :D Я так и собираю лончер под SUSE:

  • Убедитесь, что установлены пакеты (аналогичные деб-названия сами придумайте) libqt5-qtbase-devel >= 5.3, libQt5WebKitWidgets-devel >= 5.3, quazip-devel

  • Убедитесь, что у вас вообще установлен Qt5 >= 5.3, потому что это зависимость. Главная зависимость. Может вы с Qt 5.1 собираете?

  • Убедитесь, что установлены следующие компоненты Qt5: libQt5Core5, libQt5Gui5, libQt5WebKitWidgets5, libQt5Widgets5, libQt5Network5.

  • Убедитесь, что вы запускаете qmake именно от Qt5. Проверьте Makefile после его генерации на всякую ересь, вроде линковки с Qt4. Да, оно не должно быть с qmake от Qt5, но а вдруг в вашем дебиане кривой qmake?

  • Убедитесь, что вы линкуете qt5-версию quazip. Падать оно не будет, но и архивы распаковывать не будет. Вот тебе и "ненайденный lwjgl".

  • После make, убедитесь с помощью ldd, что всякая ересь не слинкована.

Больше я не знаю что делать с вашим дебианом. Мне что, его в виртуалку поставить, и собрать вам назло без кривоты? Подумайте, что вы делаете не так.

Все пакеты вроде бы нашёл, применил libquazip-qt5, в Makefile не нашёл ни одного намёка на qt4. Удалось запустить следующим способом: выйти из KDE, войти в Gnome, выполнить команду sudo mv /usr/lib/x86_64-linux-gnu/libQtGui.so.4 /usr/lib/x86_64-linux-gnu/libQtGui.so.4.b, и затем запустить. В лаунчере плохо работает виджет с окном браузера: внутренние ссылки открываются не в том же окне, а запускается внешний браузер

(16:35:45) LauncherWindow >> Try to open url in external browser. https://ttyh.ru/viewforum.php?id=2

Страница "новости Minecraft" Загружается через раз, иногда в консоли проскакивает такой лог:

Spoiler

*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: Services is null
Full stack: exports.IO.lineBreak@resource://gre/modules/addons/XPIProvider.jsm -> file:///usr/share/mozilla/extensions/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D/bootstrap.js -> file:///usr/share/mozilla/extensions/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D/lib/io.js:41:9
exports.IO.writeToFile/<@resource://gre/modules/addons/XPIProvider.jsm -> file:///usr/share/mozilla/extensions/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D/bootstrap.js -> file:///usr/share/mozilla/extensions/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D/lib/io.js:243:13
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************
*************************
A coding exception was thrown in a Promise rejection callback.

Full message: TypeError: Cr is null
See https://developer.mozilla.org/Mozilla/J … sm/Promise
Full stack: exports.ElemHide.apply/<@resource://gre/modules/addons/XPIProvider.jsm -> file:///usr/share/mozilla/extensions/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D/bootstrap.js -> file:///usr/share/mozilla/extensions/%7Bec8030f7-c20a-464f-9b0e-13a3a9e97384%7D/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D/lib/elemHide.js:259:11
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:866:9
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************

Сама игра при этом успешно скачивается, запускается и подключается к серверу

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.21 (KHTML, like Gecko) konqueror/4.14.1 Safari/537.21